summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-03-20 03:49:22 -0400
committerMark H Weaver <mhw@netris.org>2014-03-20 05:07:35 -0400
commit809e9b52bb305e7a1cac7fa0e7605102e52772af (patch)
tree2656936eb83ad0cb2e6664f9fd17e7cf2cb7db39 /gnu
parentf6b272fa18b75b53ee1456c53cb479a03914e1cd (diff)
downloadguix-809e9b52bb305e7a1cac7fa0e7605102e52772af.tar.gz
gnu: unzip: Install man pages in share/man.
* gnu/packages/zip.scm (unzip): Substitute /share/man/ for /man/ in Makefile.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/zip.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/zip.scm b/gnu/packages/zip.scm
index c0fd8c519e..03f3bc22ea 100644
--- a/gnu/packages/zip.scm
+++ b/gnu/packages/zip.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -89,7 +90,9 @@ Compression ratios of 2:1 to 3:1 are common for text files.")
          (lambda* (#:key inputs outputs #:allow-other-keys)
            (let* ((out (assoc-ref outputs "out")))
              (copy-file "unix/Makefile" "Makefile")
-             (substitute* "Makefile" (("/usr/local") out))))
+             (substitute* "Makefile"
+               (("/usr/local") out)
+               (("/man/") "/share/man/"))))
         %standard-phases)))
     (home-page "http://www.info-zip.org/UnZip.html")
     (synopsis "Unzip decompression and file extraction utility")