summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 00:52:10 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:45 -0400
commit3a4d3838d62239e9273506fe0577857114f11c1b (patch)
tree78dda3935f1c695edd251cf97702afa8590162aa /gnu
parent07e88fc63b3a4e92a943491f7aaa97dd7da56180 (diff)
downloadguix-3a4d3838d62239e9273506fe0577857114f11c1b.tar.gz
gnu: Add go-github-com-gogo-protobuf.
* gnu/packages/syncthing.scm (go-github-com-gogo-protobuf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/syncthing.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 4061ee3e6f..fdf6f464ef 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -188,6 +188,42 @@ structs in the Go programming language.")
       (home-page "https://github.com/gobwas/glob")
       (license expat))))
 
+(define-public go-github-com-gogo-protobuf
+  (let ((commit "efccd33a0c20aa078705571d5ddbfa14c8395a63")
+        (revision "0"))
+    (package
+      (name "go-github-com-gogo-protobuf")
+      (version (git-version "0.2" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/gogo/protobuf")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "09kfa3aqmhh7p0rc6wd4fw5cjccidsk9vgcy13albv0g8vnbmmgw"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/gogo/protobuf/proto"
+         #:unpack-path "github.com/gogo/protobuf"))
+      (propagated-inputs
+       `(("go-github-com-gogo-protobuf-protoc-gen-gogo"
+          ,go-github-com-gogo-protobuf-protoc-gen-gogo)))
+      (synopsis "Protocol Buffers for Go with Gadgets")
+      (description "Gogoprotobuf is a fork of golang/protobuf with extra code
+generation features.  This code generation is used to achieve:
+@itemize
+@item fast marshalling and unmarshalling
+@item more canonical Go structures
+@item goprotobuf compatibility
+@item less typing by optionally generating extra helper code
+@item peace of mind by optionally generating test and benchmark code
+@item other serialization formats
+@end itemize")
+      (home-page "https://github.com/gogo/protobuf")
+      (license bsd-3))))
+
 (define-public go-github-com-gogo-protobuf-protoc-gen-gogo
   (let ((commit "efccd33a0c20aa078705571d5ddbfa14c8395a63")
         (revision "0"))