summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPjotr Prins <pjotr.public12@thebird.nl>2015-09-15 13:32:34 +0000
committerDavid Thompson <dthompson2@worcester.edu>2015-09-19 12:31:42 -0400
commit28c5d42d354c6e902529d3c6e55138ee942461d0 (patch)
treec5df1a901806dd4008a87643a23a14878cd9b9c8 /gnu
parent7ac4610f7e00a08e3d05eb49b488043b3f0005a7 (diff)
downloadguix-28c5d42d354c6e902529d3c6e55138ee942461d0.tar.gz
gnu: Add ruby-libxml.
* gnu/packages/ruby.scm (ruby-libxml): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d80d3aa424..c906361971 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -489,6 +489,34 @@ extensions.")
     (home-page "http://codeforpeople.com/lib/ruby/orderedhash/")
     (license license:public-domain)))
 
+(define-public ruby-libxml
+  (package
+    (name "ruby-libxml")
+    (version "2.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "libxml-ruby" version))
+       (sha256
+        (base32
+         "1dhjqp4r9vkdp00l6h1cj8qfndzxlhlxk6b9g0w4v55gz857ilhb"))))
+    (build-system ruby-build-system)
+    (inputs
+     `(("zlib" ,zlib)
+       ("libxml2" ,libxml2)))
+    (arguments
+     '(#:tests? #f ; test suite hangs for unknown reason
+       #:gem-flags
+       (list "--"
+             (string-append "--with-xml2-include="
+                            (assoc-ref %build-inputs "libxml2")
+                            "/include/libxml2" ))))
+    (synopsis "Ruby bindings for GNOME Libxml2")
+    (description "The Libxml-Ruby project provides Ruby language bindings for
+the GNOME Libxml2 XML toolkit.")
+    (home-page "http://xml4r.github.com/libxml-ruby")
+    (license license:expat)))
+
 (define-public ruby-xml-simple
   (package
     (name "ruby-xml-simple")