summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-13 11:19:26 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-13 13:52:15 -0500
commit417e11bfaa7b6fb3b2b8584ed9f03f98e343a50c (patch)
tree0f19e5ebf342c695f08bfa46e864531663db8951 /gnu
parent6ebe790bce26a036945062f3e9ad7790c3bc45ac (diff)
downloadguix-417e11bfaa7b6fb3b2b8584ed9f03f98e343a50c.tar.gz
gnu: Add Class-Method-Modifiers.
* gnu/packages/perl.scm (perl-class-method-modifiers): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index bc836d9ca2..78d6bc93e1 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -534,6 +534,31 @@ names, not Class::Name.  For that, this module provides \"load_class
 Class::Load")
     (license artistic2.0)))
 
+(define-public perl-class-method-modifiers
+  (package
+    (name "perl-class-method-modifiers")
+    (version "2.11")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
+                           "Class-Method-Modifiers-" version ".tar.gz"))
+       (sha256
+        (base32
+         "14nk2gin9cjwpysakli7f0gs4q1w220sn73xzv35rhlspngrggyy"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-fatal" ,perl-test-fatal)
+       ("perl-test-requires" ,perl-test-requires)))
+    (home-page "http://search.cpan.org/dist/Class-Method-Modifiers")
+    (synopsis "Moose-like method modifiers")
+    (description "Class::Method::Modifiers provides three modifiers: before,
+around, and after.  before and after are run just before and after the method
+they modify, but can not really affect that original method.  around is run in
+place of the original method, with a hook to easily call that original
+method.")
+    (license (package-license perl))))
+
 (define-public perl-class-tiny
   (package
     (name "perl-class-tiny")