summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-05-01 12:01:43 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-05-02 09:27:18 +0200
commit6e7302e93ba336d9810bbe9c50ee5b2fedf19809 (patch)
tree8ec715f38293fd94ff3d20f1bfb5ce18b0e5e059 /gnu
parentf3f8d159c3e4b30861bbd3082bc422bb80b5b823 (diff)
downloadguix-6e7302e93ba336d9810bbe9c50ee5b2fedf19809.tar.gz
gnu: Add python-flask-oidc.
Fixes <https://bugs.gnu.org/26731>.

* gnu/packages/python.scm (python-flask-oidc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7fbf44fe97..5df679935f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14080,3 +14080,29 @@ exception message with a traceback that points to the culprit.")
     (description "@code{python-oauth2client} provides an OAuth 2.0 client
 library for Python")
     (license license:asl2.0)))
+
+(define-public python-flask-oidc
+  (package
+    (name "python-flask-oidc")
+    (version "1.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "flask-oidc" version))
+       (sha256
+        (base32
+         "1ay5j0mf174bix7i67hclr95gv16z81fpx0dijvi0gydvdj3ddy2"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-flask" ,python-flask)
+       ("python-itsdangerous" ,python-itsdangerous)
+       ("python-oauth2client" ,python-oauth2client)
+       ("python-six" ,python-six)))
+    (native-inputs
+     `(("python-nose" ,python-nose)
+       ("python-mock" ,python-mock)))
+    (home-page "https://github.com/puiterwijk/flask-oidc")
+    (synopsis "OpenID Connect extension for Flask")
+    (description "@code{python-flask-oidc} provides an OpenID Connect extension
+for Flask.")
+    (license license:bsd-2)))