summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-13 11:52:22 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-13 13:52:15 -0500
commit77917f67fdfe5e563f8e983e79f3bc05de927f47 (patch)
tree7c03bc536f0158ed760386b1d497ef693d30fd25 /gnu
parent6e1bb8aab946f492efc0860e88d1649b4ba2fc94 (diff)
downloadguix-77917f67fdfe5e563f8e983e79f3bc05de927f47.tar.gz
gnu: Add strictures.
* gnu/packages/perl.scm (perl-strictures): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 5ee92c6fe6..0e804abd4e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2429,6 +2429,25 @@ buffered.  It uses PerlIO and/or temporary file to save the buffer depending
 on the length of the size.")
     (license (package-license perl))))
 
+(define-public perl-strictures
+  (package
+    (name "perl-strictures")
+    (version "1.005005")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/H/HA/HAARG/"
+                           "strictures-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1bmpv8wr9jbc1lfj634xhq3y42nm28hh01jfsyzxhqhqf6dkdz59"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/strictures")
+    (synopsis "Turn on strict and make all warnings fatal")
+    (description "Strictures turns on strict and make all warnings fatal when
+run from within a source-controlled directory.")
+    (license (package-license perl))))
+
 (define-public perl-string-rewriteprefix
   (package
     (name "perl-string-rewriteprefix")