summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVicente Vera Parra <vicentemvp@gmail.com>2015-09-15 14:17:50 -0300
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-21 10:48:26 +0200
commitad3f005bddcca58c9f4869fffb8aef0cf4efb598 (patch)
tree83d658fbfec7d5a57830308d6bf83717af2ed057 /gnu
parentc5bf3abe34718991a9441e0f036a6d1d86731bf7 (diff)
downloadguix-ad3f005bddcca58c9f4869fffb8aef0cf4efb598.tar.gz
gnu: Add r-highr.
* gnu/packages/statistics.scm (r-highr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index ff7f0174e5..5cf094c0ee 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -600,3 +600,22 @@ indent will be added to the code automatically, and comments will be preserved
 under certain conditions, so that R code will be more human-readable and tidy.
 There is also a Shiny app as a user interface in this package.")
     (license license:gpl3+)))
+
+(define-public r-highr
+  (package
+    (name "r-highr")
+    (version "0.5.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "highr" version))
+              (sha256
+               (base32
+                "11hyawzhaw3ph5y5xphi7alx6df1d0i6wh0a2n5m4sxxhdrzswnb"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/yihui/highr")
+    (synopsis "Syntax highlighting for R source code")
+    (description
+     "This package provides syntax highlighting for R source code.  Currently
+it supports LaTeX and HTML output.  Source code of other languages is
+supported via Andre Simon's highlight package.")
+    (license license:gpl3+)))