summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-21 18:41:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 00:20:10 +0200
commitda6f345c7104dfd39911ec9f27b19107ae63ef32 (patch)
tree66be9d858b2a40542dabf28e7094cff3705cbd19 /gnu
parentbf6edb95965805cf46c6e9d7115293d08501e022 (diff)
downloadguix-da6f345c7104dfd39911ec9f27b19107ae63ef32.tar.gz
gnu: handbrake: Return #t from all phases.
* gnu/packages/video.scm (handbrake)[arguments]: Substitute INVOKE for
SYSTEM*.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 68c5d8e965..d76ab881d2 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2363,7 +2363,7 @@ supported players in addition to this package.")
              ;; Patch the Makefile so that it doesn't bootstrap again.
              (substitute* "gtk/module.rules"
                ((".*autogen\\.sh.*") ""))
-             (zero? (system* "sh" "./gtk/autogen.sh"))))
+             (invoke "sh" "./gtk/autogen.sh")))
          (add-before 'configure 'disable-contrib
            (lambda _
              (substitute* "make/include/main.defs"
@@ -2385,9 +2385,9 @@ supported players in addition to this package.")
              ;; errors on unrecognized arguments,
              ;; e.g. --enable-fast-install
              (let ((out (assoc-ref outputs "out")))
-               (zero? (apply system* "./configure"
-                             (string-append "--prefix=" out)
-                             (or configure-flags '()))))))
+               (apply invoke "./configure"
+                      (string-append "--prefix=" out)
+                      (or configure-flags '())))))
          (add-after 'configure 'chdir-build
            (lambda _ (chdir "./build") #t)))))
     (home-page "https://handbrake.fr")