summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-10-12 00:48:40 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-11-03 21:38:13 +0100
commitf4c7dc5582d02de79fcec640046486b86024bf1d (patch)
treea83d78910f2e36a6483a0079daba4b3b6269dec1 /gnu
parent2ac9ba6a2914c73ff83dbd7b4ba7b47333476685 (diff)
downloadguix-f4c7dc5582d02de79fcec640046486b86024bf1d.tar.gz
gnu: Add python-oslosphinx.
* gnu/packages/openstack.scm (python-oslosphinx,
  python2-oslosphinx): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/openstack.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index fc868814f7..34e482b4cd 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -465,6 +465,36 @@ in transmittable and storable formats, such as JSON and MessagePack.")
 (define-public python2-oslo.serialization
   (package-with-python2 python-oslo.serialization))
 
+(define-public python-oslosphinx
+  (package
+    (name "python-oslosphinx")
+    (version "3.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "oslosphinx" version))
+       (sha256
+        (base32
+         "0zcshdc9s1f7hnvg0fm2ps5rak3dpnm8kqg4i21lknhmsvb7p5cb"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-requests" ,python-requests)))
+    (inputs
+      `(("python-pbr" ,python-pbr)
+        ("python-docutils" ,python-docutils)
+        ("python-hacking" ,python-hacking)
+        ("python-setuptools" ,python-setuptools)
+        ("python-sphinx" ,python-sphinx)))
+    (home-page "http://www.openstack.org/")
+    (synopsis "OpenStack sphinx extensions and theme")
+    (description
+      "This package provides themes and extensions for Sphinx documentation
+from the OpenStack project.")
+    (license asl2.0)))
+
+(define-public python2-oslosphinx
+  (package-with-python2 python-oslosphinx))
+
 (define-public python-oslotest
   (package
     (name "python-oslotest")