summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-11-10 13:15:25 +0100
committerAndreas Enge <andreas@enge.fr>2014-11-10 13:15:25 +0100
commit054a3921f09e6670522030829d6367cb1275ba7a (patch)
treed682f3f60eae79ae86c274893c86f5f24a9a9fdd /gnu
parentbcc046fc8793f4a6835ed5519cea076f04565f82 (diff)
downloadguix-054a3921f09e6670522030829d6367cb1275ba7a.tar.gz
gnu: Add polkit-qt.
* gnu/packages/polkit.scm (polkit-qt): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/polkit.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index 64576f6473..40e56bae4f 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -20,6 +20,7 @@
   #:use-module ((guix licenses) #:select (lgpl2.0+ mpl2.0))
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages glib)
@@ -27,6 +28,7 @@
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages xml))
 
 (define-public mozjs
@@ -133,3 +135,33 @@ privileged processes.  It is a framework for centralizing the decision
 making process with respect to granting access to privileged operations
 for unprivileged applications.")
     (license lgpl2.0+)))
+
+(define-public polkit-qt
+  (package
+    (name "polkit-qt")
+    (version "1-0.112.0")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "http://download.kde.org/stable/apps/KDE4.x/admin/"
+                   name "-" version ".tar.bz2"))
+             (sha256
+              (base32
+               "1ip78x20hjqvm08kxhp6gb8hf6k5n6sxyx6kk2yvvq53djzh7yv7"))))
+    (build-system cmake-build-system)
+    (inputs
+      `(("glib" ,glib)
+        ("polkit" ,polkit)))
+    (propagated-inputs
+      `(("qt" ,qt-4))) ; according to the pkg-config files
+    (native-inputs
+      `(("pkg-config", pkg-config)))
+    (arguments
+      `(#:tests? #f)) ; there is a test subdirectory, but no test target
+    (home-page "http://api.kde.org/kdesupport-api/polkit-qt-1-apidocs/")
+    (synopsis "Qt frontend to the polkit library")
+    (description "Polkit-qt is a library that lets developers use the
+PolicyKit API through a Qt-styled API.  It is mainly a wrapper around
+QAction and QAbstractButton that lets you integrate those two component
+easily with PolicyKit.")
+    (license lgpl2.0+)))