summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-04 15:00:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-04 15:00:05 +0100
commit4254b480c938dd429772cbb78301539c6bd972d8 (patch)
treea93dea8e0d2e8bf4fd943038979e29a906dca63a /gnu
parente7a53914f15fa0e86ec583b115aca9e4ff6c69a3 (diff)
downloadguix-4254b480c938dd429772cbb78301539c6bd972d8.tar.gz
gnu: Add r-capushe.
* gnu/packages/cran.scm (r-capushe): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 54031fa87a..cc23c53f4c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10681,3 +10681,24 @@ functions are provided.")
 help you to better understand object oriented programming in R, particularly
 using @code{S3}.")
     (license license:gpl3)))
+
+(define-public r-capushe
+  (package
+    (name "r-capushe")
+    (version "1.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "capushe" version))
+       (sha256
+        (base32
+         "1aa76ir1kp67hiz7dr60azyc71yzslshyc640fjh0fpw0sp5kwbc"))))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-mass" ,r-mass)))
+    (home-page "https://cran.r-project.org/web/packages/capushe/index.html")
+    (synopsis "Calibrating penalities using slope heuristics")
+    (description
+     "This package provides tools for the calibration of penalized criteria
+for model selection.  The calibration methods available are based on the slope
+heuristics.")
+    (license license:gpl2+)))