summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-06-16 13:15:17 +0200
committerLudovic Courtès <ludo@gnu.org>2017-06-20 23:40:07 +0200
commit7e9e1a36b01e5871700d96b960fba06399143144 (patch)
treee818b16d30b170b2e062e873037c0def3f9b7336 /gnu
parent7e61a16c97dd89f8eb0e303696874b5049a0c9a7 (diff)
downloadguix-7e9e1a36b01e5871700d96b960fba06399143144.tar.gz
gnu: tor: Add seccomp support.
* gnu/packages/tor.scm (tor)[inputs]: Add libseccomp.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tor.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 819092cb72..bcb5aacbdf 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -61,7 +62,8 @@
     (inputs
      `(("zlib" ,zlib)
        ("openssl" ,openssl)
-       ("libevent" ,libevent)))
+       ("libevent" ,libevent)
+       ("libseccomp", libseccomp)))
     (home-page "https://www.torproject.org/")
     (synopsis "Anonymous network router to improve privacy on the Internet")
     (description