summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-23 08:56:30 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-23 11:32:16 +0100
commitcd4c6039eab52a1ced748ee0dd1c33674799fbe8 (patch)
tree590681eb50f1d075a8b16d62a2d1a383acfc33e6 /gnu
parentee789a411cc8e10b2558f5c199ba437fe83074d7 (diff)
downloadguix-cd4c6039eab52a1ced748ee0dd1c33674799fbe8.tar.gz
gnu: fribidi: Update to 1.0.2.
* gnu/packages/fribidi.scm (fribidi): Update to 1.0.2.
[arguments]: Disable building documentation for now.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fribidi.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/fribidi.scm b/gnu/packages/fribidi.scm
index c8a91be4ef..0368779240 100644
--- a/gnu/packages/fribidi.scm
+++ b/gnu/packages/fribidi.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -26,7 +27,7 @@
 (define-public fribidi
   (package
     (name "fribidi")
-    (version "1.0.1")
+    (version "1.0.2")
     (source
       (origin
         (method url-fetch)
@@ -35,9 +36,11 @@
                         "/download/v" version "/fribidi-" version
                          ".tar.bz2"))
         (sha256
-          (base32 "1r3ll7apx4b8bhvdkwi71y06df9kvr4q3asvajswvdlh0pbq5cf1"))))
-
+          (base32 "0aw3i1g96axbr96flw4543dvhb8zlgb0w8314ks6cq2g1i9invdx"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       (list "--disable-docs")))        ; TODO: enable; requires c2man
     (synopsis "Implementation of the Unicode bidirectional algorithm")
     (description
      "GNU FriBidi is an implementation of the Unicode Bidirectional