summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-20 14:13:36 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-20 14:22:37 -0500
commitff31136edaf9565a6fcbba64b2d3b41267a108e7 (patch)
treeb7e9d3f80cb51b70233d072168971952eb7b657d /gnu
parent31831e565d8c349a5ea660af632fd58280cb1f9d (diff)
downloadguix-ff31136edaf9565a6fcbba64b2d3b41267a108e7.tar.gz
gnu: Add YAML-Tiny.
* gnu/packages/perl.scm (perl-yaml-tiny): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 767a898c90..e2393f2729 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4245,6 +4245,31 @@ it.  With this module, you can add your own magic to any variable without
 having to write a single line of XS.")
     (license (package-license perl))))
 
+(define-public perl-yaml-tiny
+  (package
+    (name "perl-yaml-tiny")
+    (version "1.66")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
+                           "YAML-Tiny-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0c17l8pvpraznpb31ncmr4wxlyww8sg8dhvp3s3q02yqll3cnygv"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-json-maybexs" ,perl-json-maybexs)
+       ("perl-module-build-tiny" ,perl-module-build-tiny)))
+    (arguments
+     `(#:tests? #f))                    ;requires Test::More >= 0.99
+    (home-page "http://search.cpan.org/dist/YAML-Tiny")
+    (synopsis "Read/Write YAML files")
+    (description "YAML::Tiny is a perl class for reading and writing
+YAML-style files, written with as little code as possible, reducing load time
+and memory overhead.")
+    (license (package-license perl))))
+
 
 ;;; Some packaged modules need versions of core modules that are newer than
 ;;; those in our perl 5.16.1.