summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-01-11 19:43:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-01-24 14:25:20 +0100
commit541ed7b03002d8888d01cf377525ad06d071d070 (patch)
treeeaf00065030a019c57f2c10241afede0842d2dd0 /gnu
parenta763ce7da9076b5b9af49fd823f6c98cf1727a0e (diff)
downloadguix-541ed7b03002d8888d01cf377525ad06d071d070.tar.gz
gnu: cross-gcc-arguments: Enable C++, disable building of libstdc++-v3.
* gnu/packages/cross-base.scm (cross-gcc-arguments)[arguments]: Disable
  building libstdc++-v3 and enable building C++ compiler.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cross-base.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index d64cdd1272..f947e7aec8 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -105,11 +105,12 @@ may be either a libc package or #f.)"
                                "--disable-libcilkrts")
                              `( ;; Disable features not needed at this stage.
                                "--disable-shared" "--enable-static"
+                               "--enable-languages=c,c++"
 
-                               ;; Disable C++ because libstdc++'s configure
-                               ;; script otherwise fails with "Link tests are not
-                               ;; allowed after GCC_NO_EXECUTABLES."
-                               "--enable-languages=c"
+                               ;; libstdc++ cannot be built at this stage
+                               ;; ("Link tests are not allowed after
+                               ;; GCC_NO_EXECUTABLES.").
+                               "--disable-libstdc++-v3"
 
                                "--disable-threads" ;libgcc, would need libc
                                "--disable-libatomic"