summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBrendan Tildesley <brendan.tildesley@openmailbox.org>2017-05-13 21:40:24 +1000
committerMarius Bakke <mbakke@fastmail.com>2017-05-19 23:49:20 +0200
commit7010d231dbef94b09c310a8ad44889bcabb2161a (patch)
tree54fcdfbbf0d8c89fbd8fcee868eb601097c6da0b /gnu
parentcd6171c1b49cbad1b38eb1f5ae5e805f029c0ec5 (diff)
downloadguix-7010d231dbef94b09c310a8ad44889bcabb2161a.tar.gz
gnu: calibre: Import dont-load-icons patch from debian.
* gnu/packages/patches/calibre-dont-load-remote-icons.patch: New file.
* gnu/packages/ebooks.scm (calibre)[source]: Add reference to patch file.
* gnu/local.mk (dist_path_DATA): Add it.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/ebook.scm1
-rw-r--r--gnu/packages/patches/calibre-dont-load-remote-icons.patch45
3 files changed, 47 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a1530af790..8cfb89ff1b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -520,6 +520,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/byobu-writable-status.patch		\
   %D%/packages/patches/cairo-CVE-2016-9082.patch			\
   %D%/packages/patches/calibre-drop-unrar.patch			\
+  %D%/packages/patches/calibre-dont-load-remote-icons.patch	\
   %D%/packages/patches/calibre-no-updates-dialog.patch		\
   %D%/packages/patches/cdparanoia-fpic.patch			\
   %D%/packages/patches/cdrtools-3.01-mkisofs-isoinfo.patch 	\
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index a2b26c931f..cc43259e26 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -80,6 +80,7 @@
             (delete-file-recursively "src/unrar")
             (delete-file "src/odf/thumbnail.py")))
         (patches (search-patches "calibre-drop-unrar.patch"
+                                 "calibre-dont-load-remote-icons.patch"
                                  "calibre-no-updates-dialog.patch"))))
     (build-system python-build-system)
     (native-inputs
diff --git a/gnu/packages/patches/calibre-dont-load-remote-icons.patch b/gnu/packages/patches/calibre-dont-load-remote-icons.patch
new file mode 100644
index 0000000000..2168263072
--- /dev/null
+++ b/gnu/packages/patches/calibre-dont-load-remote-icons.patch
@@ -0,0 +1,45 @@
+From: Martin Pitt <mpitt@debian.org>
+Date: Mon, 14 Nov 2016 22:41:24 +0100
+Subject: content-server: Don't load external URLs for privacy
+
+Spotted by lintian.
+---
+ resources/content_server/browse/browse.html | 4 +---
+ resources/content_server/index.html         | 2 +-
+ 2 files changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/resources/content_server/browse/browse.html b/resources/content_server/browse/browse.html
+index 36f7199..e615707 100644
+--- a/resources/content_server/browse/browse.html
++++ b/resources/content_server/browse/browse.html
+@@ -7,7 +7,7 @@
+     <title>..:: calibre {library} ::.. {title}</title>
+     <meta http-equiv="X-UA-Compatible" content="IE=100" />
+     <meta name="robots" content="noindex" />
+-    <link rel="icon" type="image/x-icon" href="//calibre-ebook.com/favicon.ico" />
++    <link rel="icon" type="image/x-icon" href="favicon.ico" />
+ 
+     <link rel="stylesheet" type="text/css" href="{prefix}/static/browse/browse.css" />
+     <link type="text/css" href="{prefix}/static/jquery_ui/css/humanity-custom/jquery-ui-1.8.5.custom.css" rel="stylesheet" />
+@@ -63,8 +63,6 @@
+                     <input type="image"
+                     src="{prefix}/static/button-donate.png"
+                         name="submit"></input>
+-                    <img alt="" src="https://www.paypal.com/en_US/i/scr/pixel.gif"
+-                        width="1" height="1"></img>
+                 </div>
+             </form>
+             <div id="calibre-home-link" title="Go to the calibre website"></div>
+diff --git a/resources/content_server/index.html b/resources/content_server/index.html
+index 51cc33a..e71d0e8 100644
+--- a/resources/content_server/index.html
++++ b/resources/content_server/index.html
+@@ -9,7 +9,7 @@
+         <script type="text/javascript" src="{prefix}/static/date.js" charset="utf-8"></script>
+         <script type="text/javascript" src="{prefix}/static/jquery.js" charset="utf-8"></script>
+         <script type="text/javascript" src="{prefix}/static/gui.js" charset="utf-8"></script>
+-		<link rel="icon" href="//calibre-ebook.com/favicon.ico" type="image/x-icon" />
++		<link rel="icon" href="favicon.ico" type="image/x-icon" />
+ 	</head>
+ 	<body>
+ 	    <div id="banner">