summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-09-11 02:53:07 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-09-14 13:02:53 +0200
commitb6f87ec003f993864b4555dbff448b9b6a9a9b78 (patch)
treead3aa4198a65f794313a082d55189321f3f7e962 /gnu
parent931bd7f6ce1845cae81e3e0b758a770c47e2cc90 (diff)
downloadguix-b6f87ec003f993864b4555dbff448b9b6a9a9b78.tar.gz
gnu: encfs: Update to 1.9.
* gnu/packages/crypto.scm (encfs): Update to 1.9.
[source]: Remove bundled TinyXML2 in a snippet.
[build-system]: Switch to cmake-build-system.
[arguments]: Remove autotools-related phases and configure-flags.
Don't use bundled TinyXML2. Move under *inputs.
[native-inputs]: Remove autoconf, automake, libtool, and pkg-config.
Add expect.
[inputs]: Remove boost and rlog, while adding attr and tinyxml2.
[license]: Add expat licence for new easylogging++.h file.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crypto.scm44
1 files changed, 24 insertions, 20 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index ff5b0db5fb..c0a405cde7 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -26,6 +26,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages aidc)
+  #:use-module (gnu packages attr)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages cryptsetup)
@@ -42,11 +43,14 @@
   #:use-module (gnu packages search)
   #:use-module (gnu packages serialization)
   #:use-module (gnu packages shells)
+  #:use-module (gnu packages tcl)
   #:use-module (gnu packages tls)
+  #:use-module (gnu packages xml)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu))
 
 (define-public libsodium
@@ -193,7 +197,7 @@ communication.")
 (define-public encfs
   (package
     (name "encfs")
-    (version "1.8.1")
+    (version "1.9")
     (source
      (origin
        (method url-fetch)
@@ -202,27 +206,26 @@ communication.")
                        version "/encfs-" version ".tar.gz"))
        (sha256
         (base32
-         "1lfmcsk187qr6ahy8c8959p7jrk9d5rd9kcsx572850ca3zmf0la"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:configure-flags '("--with-boost-serialization=boost_wserialization"
-                           "--with-boost-filesystem=boost_filesystem")
-       #:phases (modify-phases %standard-phases
-                  (add-before 'configure 'autoconf
-                    (lambda _
-                      (zero? (system* "autoreconf" "-vfi")))))))
+         "1gzlhq2dlwan3hll414wqinj92lb05wd4j370j190dgcalaxplih"))
+       (modules '((guix build utils)))
+       ;; Remove bundled dependencies in favour of proper inputs.
+       (snippet '(for-each delete-file-recursively
+                           (find-files "internal" "^tinyxml2-[0-9]"
+                                       #:directories? #t)))))
+    (build-system cmake-build-system)
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("gettext" ,gnu-gettext)
-       ("libtool" ,libtool)
-       ("perl" ,perl)
-       ("pkg-config" ,pkg-config)))
+     `(("gettext" ,gnu-gettext)
+
+       ;; Test dependencies.
+       ("expect" ,expect)
+       ("perl" ,perl)))
     (inputs
-     `(("boost" ,boost)
+     `(("attr" ,attr)
        ("fuse" ,fuse)
        ("openssl" ,openssl)
-       ("rlog" ,rlog)))
+       ("tinyxml2" ,tinyxml2)))
+    (arguments
+     `(#:configure-flags (list "-DUSE_INTERNAL_TINYXML=OFF")))
     (home-page "https://vgough.github.io/encfs")
     (synopsis "Encrypted virtual file system")
     (description
@@ -231,8 +234,9 @@ created under an EncFS mount point is stored as a separate encrypted file on
 the underlying file system.  Like most encrypted file systems, EncFS is meant
 to provide security against off-line attacks, such as a drive falling into
 the wrong hands.")
-    (license (list license:lgpl3+                 ;encfs library
-                   license:gpl3+))))              ;command-line tools
+    (license (list license:expat                  ; internal/easylogging++.h
+                   license:lgpl3+                 ; encfs library
+                   license:gpl3+))))              ; command-line tools
 
 (define-public keyutils
   (package