summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 17:15:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:13:30 +0100
commit2d7db192260f59b996d16e239bb9211375ec31c3 (patch)
treecf1584caab3598e97d1de1166eb2f032576de9ee /gnu
parent7904d6fa2c5b78958a5f9b39dad4d2446df26fd9 (diff)
downloadguix-2d7db192260f59b996d16e239bb9211375ec31c3.tar.gz
gnu: python-cram: Use INVOKE.
* gnu/packages/python-xyz.scm (python-cram)[arguments]: Unconditionally return
 #T from "check" phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2a3b5b56f7..bf987b716b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5810,7 +5810,7 @@ pseudo terminal (pty), and interact with both the process and its pty.")
              (add-installed-pythonpath inputs outputs)
              (setenv "PATH" (string-append (getenv "PATH") ":"
                                            (assoc-ref outputs "out") "/bin"))
-             (zero? (system* "make" "test")))))))
+             (invoke "make" "test"))))))
     (build-system python-build-system)
     (native-inputs
      `(("python-coverage" ,python-coverage)