summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-29 15:14:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-29 15:14:13 +0200
commit3b1886c9dd6941d753f6f2f17a30ec3ea69fc47e (patch)
treee6899b5f56adf05775c64e2617f613c924e69646 /gnu
parent05fa5a84facc80aa6d7f3fe8fe4bf106aa043c93 (diff)
downloadguix-3b1886c9dd6941d753f6f2f17a30ec3ea69fc47e.tar.gz
gnu: emacs-flycheck-grammalecte: Fix location for external executables.
* gnu/packages/emacs-xyz.scm (emacs-flycheck-grammalecte)[inputs]: Add curl.
[arguments]: Fix path to all "python", "python3" and "curl" occurrences.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9d40b8019e..9199e56997 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3381,13 +3381,16 @@ for Flow files.")
      `(#:include '("\\.(el|py)$")
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'fix-python
-           ;; Hardcode python3 executable in the Emacs library.
+         (add-after 'unpack 'set-external-executables
+           ;; Hardcode python3 and curl executables in the Emacs library.
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((python3 (string-append (assoc-ref inputs "python")
-                                           "/bin/python3")))
+                                           "/bin/python3"))
+                   (curl (string-append (assoc-ref inputs "curl")
+                                        "/bin/curl")))
                (substitute* "flycheck-grammalecte.el"
-                 (("python3") python3))
+                 (("\"python3?") (string-append "\"" python3))
+                 (("\"curl") (string-append "\"" curl)))
                #t)))
          (add-after 'install 'link-to-grammalecte
            ;; The package expects grammalecte to be in a sub-directory.
@@ -3404,7 +3407,8 @@ for Flow files.")
                           "grammalecte"))
                #t))))))
     (inputs
-     `(("grammalecte" ,grammalecte)
+     `(("curl" ,curl)
+       ("grammalecte" ,grammalecte)
        ("python" ,python)))
     (propagated-inputs
      `(("emacs-flycheck" ,emacs-flycheck)))