summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-03-30 22:42:28 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-03-31 09:41:54 +0200
commit479e74d603c6f0fd5549157df904cfad1761d7a2 (patch)
treeabda56dfeeecfd6fe25180e0fd88f191ac8af2df /gnu
parent5450e30172a977a7f0b13a48f9ee2bb681010426 (diff)
downloadguix-479e74d603c6f0fd5549157df904cfad1761d7a2.tar.gz
gnu: procenv: Make some inputs native & make multiline.
* gnu/packages/linux.scm (procenv)[native-inputs]: New field.
[inputs]: Move groff to native-inputs, move each remaining item on its own line.

Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a45847cbe5..945c15d972 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5867,9 +5867,11 @@ the MTP device as a file system.")
       (base32 "1javw97yw0qvjmj14js8vw6nsfyf2xc0kfiyq5f2hsp0553w2cdq"))))
    (build-system gnu-build-system)
    (arguments `(#:configure-flags '("--disable-silent-rules")))
-   (native-inputs `(("pkg-config" ,pkg-config)))
-   (inputs `(("expat" ,expat) ("libcap" ,libcap) ("check" ,check)
-             ("groff" ,groff)           ; for tests
+   (native-inputs `(("groff" ,groff) ; for tests
+                    ("pkg-config" ,pkg-config)))
+   (inputs `(("check" ,check)
+             ("expat" ,expat)
+             ("libcap" ,libcap)
              ("libselinux" ,libselinux)))
    (synopsis "Utility to show process environment")
    (description "Procenv is a command-line tool that displays as much detail about