summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 16:40:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:37 +0100
commit647ff4a98b422028c162fb4f861ad9d323a4cadf (patch)
tree145f5041d6b3fdc0f82216fdada5ae496a197716 /gnu
parent8fed766a7d3988ec39861c546507b945da9c84d9 (diff)
downloadguix-647ff4a98b422028c162fb4f861ad9d323a4cadf.tar.gz
gnu: Add r-abcadm.
* gnu/packages/cran.scm (r-abcadm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8916e50f10..b7555f959c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16250,3 +16250,28 @@ tests, two samples independent (unpaired) t test and analysis of variance.")
 methylated between cases and controls.  It applies Student's t-test and delta
 beta analysis to identify candidate genes containing multiple CpG sites.")
     (license license:gpl3)))
+
+(define-public r-abcadm
+  (package
+    (name "r-abcadm")
+    (version "1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "abcADM" version))
+       (sha256
+        (base32
+         "0vcabnnnwc0psv9v3rda5aap9s8cq1pjh02zva3ki64hlavf2a10"))))
+    (properties `((upstream-name . "abcADM")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bh" ,r-bh)
+       ("r-rcpp" ,r-rcpp)))
+    (home-page "https://cran.r-project.org/web/packages/abcADM/")
+    (synopsis "Fit accumulated damage models and estimate reliability using ABC")
+    (description
+     "This package provides tools to estimate parameters of accumulated
+damage (load duration) models based on failure time data under a Bayesian
+framework, using @dfn{Approximate Bayesian Computation} (ABC), and to assess
+long-term reliability under stochastic load profiles.")
+    (license license:gpl3)))