summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-25 12:37:04 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:43 +0200
commit8c28fbc3bef2c4ece6fb07a0b81a35fb89b85db3 (patch)
tree24e5fd445b7cc0b8bc3df9410d3f96f29168c134 /gnu
parent0e52427150044afecefd9f4534d491a6b569e5e2 (diff)
downloadguix-8c28fbc3bef2c4ece6fb07a0b81a35fb89b85db3.tar.gz
gnu: Add rust-webpki-0.18.
* gnu/packages/crates-io.scm (rust-webpki-0.18): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ccda9bf203..9ade4b73d6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -26668,6 +26668,25 @@ protocol extensions.  Look at the crate wayland-client for usable bindings.")
 Verification.")
     (license license:isc)))
 
+(define-public rust-webpki-0.18
+  (package/inherit rust-webpki-0.21
+    (name "rust-webpki")
+    (version "0.18.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "webpki" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0zx1v8afa4ig97dyqfrnlj5i7pib6dnfw88qn2iiqhfq2rrrdmqp"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-ring" ,rust-ring-0.13)
+        ("rust-untrusted" ,rust-untrusted-0.6))
+       #:cargo-development-inputs
+       (("rust-base64" ,rust-base64-0.9))))))
+
 (define-public rust-weedle-0.10
   (package
     (name "rust-weedle")