summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@openmailbox.org>2015-04-30 22:26:57 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-04 23:30:51 +0200
commit934d37069436b3f8e65478f0a5329ef0d72fdb15 (patch)
treee14d9c2d85af2de3ccaebf035479e85551c5dcfa /gnu
parent5e6039a48b136d34d21b34237617d77580566e51 (diff)
downloadguix-934d37069436b3f8e65478f0a5329ef0d72fdb15.tar.gz
gnu: Add markdown.
* gnu/packages/textutils.scm (markdown): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/textutils.scm50
1 files changed, 49 insertions, 1 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 08b1b64c57..325386d234 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
+;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -23,8 +24,11 @@
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system trivial)
   #:use-module (gnu packages autotools)
-  #:use-module (gnu packages python))
+  #:use-module (gnu packages perl)
+  #:use-module (gnu packages python)
+  #:use-module (gnu packages zip))
 
 (define-public recode
   (package
@@ -155,3 +159,47 @@ encoding, supporting Unicode version 7.0.")
      "libgtextutils is a text utilities library used by the fastx toolkit from
 the Hannon Lab.")
     (license license:agpl3+)))
+
+(define-public markdown
+  (package
+    (name "markdown")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://daringfireball.net/projects/downloads/"
+             (string-capitalize name) "_" version ".zip"))
+       (sha256
+        (base32 "0dq1pj91pvlwkv0jwcgdfpv6gvnxzrk3s8mnh7imamcclnvfj835"))))
+    (build-system trivial-build-system)
+    (arguments
+     '(#:modules ((guix build utils))
+       #:builder
+       (begin
+         (use-modules (guix build utils))
+         (let ((source (assoc-ref %build-inputs "source"))
+               (out    (assoc-ref %outputs "out"))
+               (perlbd (string-append (assoc-ref %build-inputs "perl") "/bin"))
+               (unzip  (string-append (assoc-ref %build-inputs "unzip")
+                                      "/bin/unzip")))
+           (mkdir-p out)
+           (with-directory-excursion out
+             (system* unzip source)
+             (mkdir "bin")
+             (mkdir-p "share/doc")
+             (rename-file "Markdown_1.0.1/Markdown.pl" "bin/markdown")
+             (rename-file "Markdown_1.0.1/Markdown Readme.text"
+                          "share/doc/README")
+             (patch-shebang "bin/markdown" (list perlbd))
+             (delete-file-recursively "Markdown_1.0.1"))))))
+    (native-inputs `(("unzip" ,unzip)))
+    (inputs `(("perl" ,perl)))
+    (home-page "http://daringfireball.net/projects/markdown")
+    (synopsis "Text-to-HTML conversion tool")
+    (description
+     "Markdown is a text-to-HTML conversion tool for web writers.  It allows
+you to write using an easy-to-read, easy-to-write plain text format, then
+convert it to structurally valid XHTML (or HTML).")
+    (license (license:non-copyleft "file://License.text"
+                                   "See License.text in the distribution."))))