summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-01-04 00:46:32 +0100
committerRoel Janssen <roel@gnu.org>2018-01-04 00:46:32 +0100
commitd5456444f7032e7bc9168db2b59e548672795b72 (patch)
treeedb6c34b5bb72dca441fb69655f3a1768dc964bb /gnu
parent690c9c18a55c8c365f34c0052927c7d64e4cf015 (diff)
downloadguix-d5456444f7032e7bc9168db2b59e548672795b72.tar.gz
gnu: vlc: Enable libdvdread and libdvdcss support.
* gnu/packages/video.scm (libdvdread): Compile with libdvdcss support;
  (vlc): Add libdvdread as input.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2d638abfe8..e64c1e0895 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -22,6 +22,7 @@
 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -831,6 +832,7 @@ audio/video codec library.")
        ("libcddb" ,libcddb)
        ("libdvbpsi" ,libdvbpsi)
        ("libgcrypt" ,libgcrypt)
+       ("libdvdread" ,libdvdread)
        ("libkate" ,libkate)
        ("libmad" ,libmad)
        ("libogg" ,libogg)
@@ -1359,6 +1361,12 @@ players, like VLC or MPlayer.")
     (build-system gnu-build-system)
     (home-page "http://dvdnav.mplayerhq.hu/")
     (synopsis "Library for reading video DVDs")
+    (arguments
+     `(#:configure-flags '("--with-libdvdcss=yes")))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libdvdcss" ,libdvdcss)))
     (description
      "Libdvdread provides a simple foundation for reading DVD video
 disks.  It provides the functionality that is required to access many