summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-14 12:47:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-18 00:36:08 +0200
commit08e977d291a5426be15f0ddb204a3a7004bd9e92 (patch)
treee61b09662d0467dca0779f484d4a164309d9d072 /gnu
parent2495012709f7c23deb9dd88d8c5ed10f9bf3d42e (diff)
downloadguix-08e977d291a5426be15f0ddb204a3a7004bd9e92.tar.gz
gnu: physfs: Update to 3.0.1.
* gnu/packages/game-development.scm (physfs): Update to 3.0.1.
[arguments]: Add phase to ensure RUNPATH is set.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/game-development.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index afabeb0c62..fde139c0b7 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -518,7 +518,7 @@ sounds from presets such as \"explosion\" or \"powerup\".")
 (define-public physfs
   (package
     (name "physfs")
-    (version "2.0.3")
+    (version "3.0.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -527,10 +527,18 @@ sounds from presets such as \"explosion\" or \"powerup\".")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0sbbyqzqhyf0g68fcvvv20n3928j0x6ik1njmhn1yigvq2bj11na"))))
+                "1wgj2zqpnfbnyyi1i7bq5pshcc9n5cvwlpzp8im67nb8662ryyxp"))))
     (build-system cmake-build-system)
     (arguments
-     '(#:tests? #f))                    ; no check target
+     '(#:tests? #f                      ; no check target
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'patch-CMakeLists.txt
+                    (lambda _
+                      (substitute* "CMakeLists.txt"
+                        ;; XXX: For some reason CMakeLists.txt disables
+                        ;; RUNPATH manipulation when the compiler is GCC.
+                        (("CMAKE_COMPILER_IS_GNUCC") "FALSE"))
+                      #t)))))
     (inputs
      `(("zlib" ,zlib)))
     (native-inputs