summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-07-28 11:08:16 -0400
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2020-07-28 11:10:24 -0400
commit305b388ca84ea943fc724846e85aff264693988f (patch)
treedf309e8710465b9b46a92404867d5f3368d33a3e /gnu
parent0c121f484a5ffaff80449af1cdf420b690cffcdd (diff)
downloadguix-305b388ca84ea943fc724846e85aff264693988f.tar.gz
gnu: Add emacs-spaceline-next.
This version tracks emacs-spaceline from git... the latest stable release is
several years old and has various bugs related to the ERC track bar, amongst
other things.

* gnu/packages/emacs-xyz.scm (emacs-spaceline-next): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c0014f0b94..44f8c44233 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017, 2018, 2019 Chris Marusich <cmmarusich@gmail.com>
-;;; Copyright © 2015, 2016, 2018 Christopher Lemmer Webber <cwebber@dustycloud.org>
+;;; Copyright © 2015, 2016, 2018, 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2016 Adriano Peluso <catonano@gmail.com>
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
@@ -18328,6 +18328,24 @@ scratch, and you think the Spacemacs theme looks good.
 @end itemize")
     (license license:gpl3+)))
 
+(define-public emacs-spaceline-next
+  (let ((commit "1b26af2c1a701481ac5d90928fe0200e389756c3")
+        (last-release-version "2.0.1")
+        (revision "0"))
+    (package
+      (inherit emacs-spaceline)
+      (name "emacs-spaceline-next")
+      (version (git-version last-release-version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/TheBB/spaceline.git")
+               (commit commit)))
+         (sha256
+          (base32 "11lwckqcgzsahrkkm5wk1ph4kc7d4yz05r7251g8c9f0q6vdj9dp"))
+         (file-name (git-file-name name version)))))))
+
 (define-public emacs-column-marker
   (package
     (name "emacs-column-marker")