summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-18 23:15:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-18 23:15:50 +0200
commit40a7153d198821c4111d5bb864f872d2df108013 (patch)
tree41316274b6e88d989cfd8b736fd288851ff0ee8d /gnu
parente77947db06339a38979d9ef838ca9ed00d527db2 (diff)
downloadguix-40a7153d198821c4111d5bb864f872d2df108013.tar.gz
gnu: python-flake8-polyfill: Adjust tests for Pytest 4.
* gnu/packages/python-xyz.scm (python-flake8-polyfill)[arguments]: Add
substitution in setup.cfg.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5a7a21da5d..e2ef589acf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6541,6 +6541,12 @@ complexity of Python source code.")
        (modify-phases %standard-phases
          (replace 'check
            (lambda _
+             ;; Be compatible with Pytest 4:
+             ;; https://gitlab.com/pycqa/flake8-polyfill/merge_requests/7
+             (substitute* "setup.cfg"
+               (("\\[pytest\\]")
+                "[tool:pytest]"))
+
              (setenv "PYTHONPATH"
                      (string-append (getcwd) "/build/lib:"
                                     (getenv "PYTHONPATH")))