summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-10-06 22:01:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-06 22:01:00 +0300
commit59fed2b6093afed0847316fc55a1857d70d77c70 (patch)
tree15ca268abb8037bd4ba99c37fb2a4223d46b15f6 /gnu
parent0f43f8354ccd58dcb54e2c025e99d972c5bfa65f (diff)
downloadguix-59fed2b6093afed0847316fc55a1857d70d77c70.tar.gz
gnu: nginx: Update to 1.11.4.
* gnu/packages/web.scm (nginx): Update to 1.11.4.
[source] Use https.
[home-page]: Use https.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 4901f116e3..667d2cdf25 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -121,14 +121,14 @@ and its related documentation.")
 (define-public nginx
   (package
     (name "nginx")
-    (version "1.10.1")
+    (version "1.11.4")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://nginx.org/download/nginx-"
+              (uri (string-append "https://nginx.org/download/nginx-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "00d8hxj8453c7989qd7z4f1mjp0k3ib8k29i1qyf11b4ar35ilqz"))))
+                "0fvb09ycxz3xnyynav6ybj6miwh9kv8jcb2vzrmvqhzn8cgiq8h6"))))
     (build-system gnu-build-system)
     (inputs `(("pcre" ,pcre)
               ("openssl" ,openssl)
@@ -140,7 +140,8 @@ and its related documentation.")
          (add-before 'configure 'patch-/bin/sh
            (lambda _
              (substitute* "auto/feature"
-               (("/bin/sh") (which "bash")))))
+               (("/bin/sh") (which "bash")))
+             #t))
          (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((flags
@@ -186,7 +187,7 @@ and its related documentation.")
                             (string-append share "/conf"))
                (rename-file (string-append out "/html")
                             (string-append share "/html"))))))))
-    (home-page "http://nginx.org")
+    (home-page "https://nginx.org")
     (synopsis "HTTP and reverse proxy server")
     (description
      "Nginx (\"engine X\") is a high-performance web and reverse proxy server