summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-28 05:38:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-28 05:46:20 +0200
commit6bbb287a60d6fead7755e7dc3cc1d073ab5bbb1c (patch)
tree561b6024fd94442bcc56d796d5f7add7a82fff88 /gnu
parent53ba82dda1ea0932b0e9740b831ec6aba0490886 (diff)
downloadguix-6bbb287a60d6fead7755e7dc3cc1d073ab5bbb1c.tar.gz
gnu: r-flexdashboard: Update to 0.5.2.
* gnu/packages/cran.scm (r-flexdashboard): Update to 0.5.2.
[source]: Delete minified JavaScript files in a snippet.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4a39543bf1..6a498a8daa 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15159,17 +15159,28 @@ matrix and displays the significance level on the plot.  It also includes a
 function for computing a matrix of correlation p-values.")
     (license license:gpl2)))
 
+;; This package includes minified JavaScript files.  When upgrading please
+;; check that there are no new minified JavaScript files.
 (define-public r-flexdashboard
   (package
     (name "r-flexdashboard")
-    (version "0.5.1.1")
+    (version "0.5.2")
     (source
      (origin
        (method url-fetch)
        (uri (cran-uri "flexdashboard" version))
        (sha256
         (base32
-         "0fy3nbrr67zqgd44r2mc850s5sp0hzfcw3zqs15m8kxzj1aw067x"))))
+         "1bh759llp15fxrx2rwvxd8p3w84vjmkid32ism7zg49a127fjib4"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           ;; Delete bundled minified JavaScript files
+           (delete-file "inst/htmlwidgets/lib/raphael/raphael-2.1.4.min.js")
+           (delete-file "inst/www/sly/sly.min.js")
+           (delete-file "inst/www/stickytableheaders/jquery.stickytableheaders.min.js")
+           (delete-file "inst/www/prism/prism.js")
+           #t))))
     (build-system r-build-system)
     (arguments
      `(#:modules ((guix build utils)
@@ -15212,7 +15223,6 @@ function for computing a matrix of correlation p-values.")
                    (for-each (lambda (source target)
                                (format #t "Processing ~a --> ~a~%"
                                        source target)
-                               (delete-file target)
                                (let ((minified (open-pipe* OPEN_READ "uglify-js" source)))
                                  (call-with-output-file target
                                    (lambda (port)