summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 01:13:05 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:47 -0400
commit6bc1eb1159f72e7285c57b1e25fcc466b059fcaf (patch)
treed2262d67f5f5de50d1ea39206a96bc861fddf7bb /gnu
parent0921b23014937639c51d25b03aa2f1210c1fe5de (diff)
downloadguix-6bc1eb1159f72e7285c57b1e25fcc466b059fcaf.tar.gz
gnu: Add go-github-com-stathat-go.
* gnu/packages/syncthing.scm (go-github-com-stathat-go): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/syncthing.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index d20a646a44..f5694580b7 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -466,6 +466,29 @@ higher-level API for doing so.")
       (home-page "https://github.com/oschwald/maxminddb-golang")
       (license isc))))
 
+(define-public go-github-com-stathat-go
+  (let ((commit "74669b9f388d9d788c97399a0824adbfee78400e")
+        (revision "0"))
+    (package
+      (name "go-github-com-stathat-go")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/stathat/go")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1zzlsl24dyr202qkr2pay22m6d0gb7ssms77wgdx0r0clgm7dihw"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/stathat/go"))
+      (synopsis "Post statistics to StatHat")
+      (description "This is a Go package for posting to a StatHat account.")
+      (home-page "https://github.com/stathat/go")
+      (license expat))))
+
 (define-public go-golang-org-x-sys-unix
   (let ((commit "f3918c30c5c2cb527c0b071a27c35120a6c0719a")
         (revision "0"))