summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-13 11:12:58 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-13 13:52:15 -0500
commit6ebe790bce26a036945062f3e9ad7790c3bc45ac (patch)
tree6fb0f39961ecc808a91bcb1e8168fda2ae01f8d9 /gnu
parent2793480ed00657d6b53780f5b9cfedf2b979b5fe (diff)
downloadguix-6ebe790bce26a036945062f3e9ad7790c3bc45ac.tar.gz
gnu: Add Module-Find.
* gnu/packages/perl.scm (perl-module-find): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 714fc0598e..bc836d9ca2 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1607,6 +1607,27 @@ replacement.  Whereas Module::Build has over 6,700 lines of code; this module
 has less than 120, yet supports the features needed by most distributions.")
     (license (package-license perl))))
 
+(define-public perl-module-find
+  (package
+    (name "perl-module-find")
+    (version "0.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/C/CR/CRENZ/"
+                           "Module-Find-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1lc33jdv4pgmm7nkr9bff0lhwjhhw91kaf6iiy2n7i7mw8dfv47l"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Module-Find")
+    (synopsis "Find and use installed modules in a (sub)category")
+    (description "Module::Find lets you find and use modules in categories.
+This can be useful for auto-detecting driver or plugin modules.  You can
+differentiate between looking in the category itself or in all
+subcategories.")
+    (license (package-license perl))))
+
 (define-public perl-module-implementation
   (package
     (name "perl-module-implementation")