summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-16 23:37:21 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:48 +0100
commitb9fc496ff65a1f5656c3e7f62220b44c23f17406 (patch)
tree0ec418d3c2041899f1e3d4a5d392880788ded60c /gnu
parenta5333f7c61507e25657c7a5dd251f9b084ced886 (diff)
downloadguix-b9fc496ff65a1f5656c3e7f62220b44c23f17406.tar.gz
gnu: python-wsgi-intercept: Correct inputs.
* gnu/packages/python.scm(python-wsgi-intercept): [native-inputs]: move
  python-six to [propagated-inputs].  [propagated-inputs] move
  python-httplib2, python-requests to [native-inputs].
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e7338cbcfb..57b89efd05 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7824,13 +7824,13 @@ framework which enables you to test server connections locally.")
               (base32
                "0kjj2v2dvmnpdd5h5gk9rzz0f54rhjb0yiz3zg65bmp65slfw65d"))))
     (build-system python-build-system)
+    (propagated-inputs
+     `(("python-six" ,python-six)))
     (native-inputs
      `(("python-pytest" ,python-pytest)
-       ("python-six" ,python-six)
+       ("python-httplib2" ,python-httplib2)
+       ("python-requests" ,python-requests)
        ("python-urllib3" ,python-urllib3)))
-    (propagated-inputs
-     `(("python-httplib2" ,python-httplib2)
-       ("python-requests" ,python-requests)))
     (synopsis "Puts a WSGI application in place of a real URI for testing")
     (description "Wsgi_intercept installs a WSGI application in place of a real
 URI for testing.  Testing a WSGI application normally involves starting a