summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <leungbk@mailfence.com>2019-10-06 22:02:46 +0200
committerBrian Leung <leungbk@mailfence.com>2019-10-06 22:08:27 +0200
commitcb2197508a62210b8bdb132b6f96aebba637e6b3 (patch)
tree16b0ce6dac08a5b45d8473bc97bb2a03dc0699af /gnu
parent45d04b2a7d01f693020149853e1d810cf92205a4 (diff)
downloadguix-cb2197508a62210b8bdb132b6f96aebba637e6b3.tar.gz
gnu: Add emacs-helm-org.
* gnu/packages/emacs-xyz.scm (emacs-helm-org): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bfcfb98d1e..cc16a5d04f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6647,6 +6647,31 @@ considered to be its successor.  Helm sets out to clean up the legacy code in
 not tied in the trap of backward compatibility.")
     (license license:gpl3+)))
 
+(define-public emacs-helm-org
+  (let ((commit "542dda7bc9a3b9dfb439e4f8a1e5f60cfb6cc256")
+        (revision "1"))
+    (package
+      (name "emacs-helm-org")
+      (version (git-version "1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacs-helm/helm-org.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1xa32w80icrykpyfb89fhb0s4l7ysi0sc7f7lfwqz5najwbgqipl"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-helm" ,emacs-helm)))
+      (home-page "https://github.com/emacs-helm/helm-org")
+      (synopsis "Helm interface to the Silver Searcher")
+      (description
+       "This package provides a frontend for grepping tools like ag and ack,
+as well as features for editing search results.")
+      (license license:gpl3+))))
+
 (define-public emacs-helm-swoop
   (package
     (name "emacs-helm-swoop")