summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-28 16:44:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-28 16:53:09 +0300
commitce71b229ec683c263d91300a89893ff0fb9b6a9c (patch)
tree3403e0fd7b955f01037a6d7c1b45026182b0137e /gnu
parent5a77fcca3fc9c1aab1315797b8e056195308d07a (diff)
downloadguix-ce71b229ec683c263d91300a89893ff0fb9b6a9c.tar.gz
gnu: Add rust-typeable.
* gnu/packages/crates-io.scm (rust-typeable): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 952c8543b1..9ae372fb70 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1687,6 +1687,24 @@ fixed set of worker threads.")
      "This package provides a lightweight atomic lock.")
     (license license:expat)))
 
+(define-public rust-typeable
+  (package
+    (name "rust-typeable")
+    (version "0.1.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "typeable" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "11w8dywgnm32hb291izjvh4zjd037ccnkk77ahk63l913zwzc40l"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/reem/rust-typeable")
+    (synopsis "Exposes Typeable, for getting TypeIds at runtime")
+    (description "Exposes Typeable, for getting TypeIds at runtime.")
+    (license license:expat)))
+
 (define-public rust-typenum
   (package
     (name "rust-typenum")