summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorStefan Reichoer <stefan@xsteve.at>2016-09-16 23:00:06 +0200
committerLeo Famulari <leo@famulari.name>2016-09-27 14:54:58 -0400
commite8c9b010908d33c9103839b8d8fddd9e33a731ef (patch)
treeade79802c7a6299c0b9a2703e904875ef6a78eac /gnu
parentb9bc6e842066b066ebdf9eaf75d41753598d75b5 (diff)
downloadguix-e8c9b010908d33c9103839b8d8fddd9e33a731ef.tar.gz
gnu: Add python-q.
* gnu/packages/python.scm (python-q, python2-q): New variables.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 529b7fdb09..90dd1b7d4d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5008,6 +5008,35 @@ as possible in order to be comprehensible and easily extensible.")
 (define-public python2-sympy
   (package-with-python2 python-sympy))
 
+(define-public python-q
+  (package
+    (name "python-q")
+    (version "2.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "q" version))
+       (sha256
+        (base32
+         "1mgfazh8fkizh6walra2zv885f3lcgr3nb02v1frfm4p8ddcy3yy"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/zestyping/q")
+    (synopsis "Quick-and-dirty debugging output for tired programmers")
+    (description
+     "q is a Python module for \"print\" style of debugging Python code.  It
+provides convenient short API for print out of values, tracebacks, and
+falling into the Python interpreter.")
+    (license license:asl2.0)
+    (properties `((python2-variant . ,(delay python2-q))))))
+
+(define-public python2-q
+  (let ((base (package-with-python2 (strip-python2-variant python-q))))
+    (package
+      (inherit base)
+      (native-inputs
+       `(("python2-setuptools" ,python2-setuptools)
+         ,@(package-native-inputs base))))))
+
 (define-public python-testlib
   (package
     (name "python-testlib")