summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-22 12:16:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-22 12:16:48 +0300
commit2a15e9276686b00f302be40216c6e862884cb20b (patch)
treed1127100b2a46d94696bbc6194f72987137f8419 /gnu
parent839e1eb0850fcdf9dc8c08763434f9d193057a4b (diff)
downloadguix-2a15e9276686b00f302be40216c6e862884cb20b.tar.gz
gnu: libfaketime: Adjust flags on powerpc64le-linux.
* gnu/packages/check.scm (libfaketime)[arguments]: Adjust CFLAGS on
powerpc64le-linux to make package work.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index ff3eb8b891..7054db5ef7 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2694,7 +2694,13 @@ portable to just about any platform.")
 
                         ;; XXX: Without this flag, the CLOCK_REALTIME test hangs
                         ;; indefinitely.  See README.packagers for more information.
-                        (setenv "FAKETIME_COMPILE_CFLAGS" "-DFORCE_MONOTONIC_FIX"))))
+                        ;; There are specific instructions to not enable more flags
+                        ;; than absolutely needed.
+                        ,(if (target-ppc64le?)
+                           `(setenv "FAKETIME_COMPILE_CFLAGS"
+                                    "-DFORCE_MONOTONIC_FIX -DFORCE_PTHREAD_NONVER")
+                           `(setenv "FAKETIME_COMPILE_CFLAGS"
+                                    "-DFORCE_MONOTONIC_FIX")))))
                   (add-before 'check 'pre-check
                     (lambda _
                       (substitute* "test/functests/test_exclude_mono.sh"