summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 12:11:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 12:11:50 +0300
commit8ee76f611ab7eb598878d9e16c97f15accfedd87 (patch)
treee8df879d474f9d2116c82da4d263dd075ae2b895 /gnu
parent88b2c1aae21a28957ef9b53f3e9aa82355a9027e (diff)
downloadguix-8ee76f611ab7eb598878d9e16c97f15accfedd87.tar.gz
gnu: Add python-csscompressor.
* gnu/packages/python-xyz.scm (python-csscompressor): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 510729bea8..d509d51f4e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13545,6 +13545,32 @@ network.")
 (define-public python2-argcomplete
   (package-with-python2 python-argcomplete))
 
+(define-public python-csscompressor
+  (package
+    (name "python-csscompressor")
+    (version "0.9.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "csscompressor" version))
+        (sha256
+         (base32
+          "018ssffvlpnc1salmnpyl52c11glzzwj4k9f757hl4pkpjnjp8mg"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "py.test"))))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/sprymix/csscompressor")
+    (synopsis "Python port of YUI CSS Compressor")
+    (description
+     "This package provides a python port of YUI CSS Compressor.")
+    (license license:bsd-3)))
+
 (define-public python-rcssmin
   (package
     (name "python-rcssmin")