summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-07-04 23:04:19 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-22 00:03:43 +0200
commit9763102bd7fbb5435c4e2b03001b518c310db2b3 (patch)
tree04e63e01ba169b520641cd1e2b69c607836fe0c7 /gnu
parentf9984535593de3f76d0df669f15e67061e18cd24 (diff)
downloadguix-9763102bd7fbb5435c4e2b03001b518c310db2b3.tar.gz
gnu: Add python-pymysql.
* gnu/packages/databases.scm (python-pymysql, python2-pymysql): New
public variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/databases.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 9f3b22384f..b1d187f801 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -84,6 +84,7 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages popt)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages rdf)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages ruby)
@@ -872,6 +873,34 @@ pictures, sounds, or video.")
                (base32
                 "0biy8j69dbvdmrag55pdszpc0702agzqhhcwdx21xp02mzim4ydr"))))))
 
+(define-public python-pymysql
+  (package
+    (name "python-pymysql")
+    (version "0.9.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "PyMySQL" version))
+       (sha256
+        (base32
+         "0gvi63f1zq1bbd30x28kqyx351hal1yc323ckp0mihainb5n1iwy"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-unittest2" ,python-unittest2)))
+    (inputs
+     `(("python-cryptography" ,python-cryptography)))
+    (arguments
+     `(#:tests? #f))                    ; tests expect a running MySQL
+    (home-page "https://github.com/PyMySQL/PyMySQL/")
+    (synopsis "Pure-Python MySQL driver")
+    (description
+     "PyMySQL is a pure-Python MySQL client library, based on PEP 249.
+Most public APIs are compatible with @command{mysqlclient} and MySQLdb.")
+    (license license:expat)))
+
+(define-public python2-pymysql
+  (package-with-python2 python-pymysql))
+
 (define-public qdbm
   (package
     (name "qdbm")