summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-09-18 10:45:18 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:11 +0100
commitc707530c1fa4387ac1c6171ad89df89c080fd0ac (patch)
tree14df9320da4f5f0fc487ffff15f3ffb3f7b8e2a8 /gnu
parentb2b88471d6c3ca08115d5e8079cccad2b7f92369 (diff)
downloadguix-c707530c1fa4387ac1c6171ad89df89c080fd0ac.tar.gz
gnu: packagekit: Update to 1.2.5.
* gnu/packages/freedesktop.scm (packagekit): Update to 1.2.5.
[build-system]: Use meson-build-system.
[arguments]: Disable systemd. Fix xsl.
[native-inputs]: Add docbook-xsl, gobject-introspection, libxml2, libxslt and vala.
[inputs]: Add gstreamer, gst-plugins-base and gtk+.

Co-authored-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm43
1 files changed, 24 insertions, 19 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 6e496dbc99..9a588b21a6 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -983,32 +983,37 @@ with localed.  This package is extracted from the broader systemd package.")
 (define-public packagekit
   (package
     (name "packagekit")
-    (version "1.1.13")
+    (version "1.2.5")
     (source (origin
-             (method url-fetch)
-             (uri (string-append
-                   "https://www.freedesktop.org/software/"
-                   "PackageKit/releases/"
-                   "PackageKit-" version ".tar.xz"))
-             (sha256
-              (base32
-               "1dr1laic65ld95abp2yxbwvijnngh0dwyb1x49x4wjm5rhq43dl8"))))
-    (build-system gnu-build-system)
+              (method url-fetch)
+              (uri (string-append "https://www.freedesktop.org/software/"
+                                  "PackageKit/releases/" "PackageKit-" version
+                                  ".tar.xz"))
+              (sha256
+               (base32
+                "09md23m4fw87x264mls1f5isrswk6iw7y9g4hr1nib008wbbk370"))))
+    (build-system meson-build-system)
     (arguments
      (list #:tests? #f
-           #:make-flags
-           #~(list (string-append "BASH_COMPLETIONS_DIR="
-                                  #$output "/etc/bash_completion.d"))
-           #:configure-flags #~'("--disable-systemd")))
+           #:configure-flags #~'("-Dsystemd=false" "-Doffline_update=false")))
     (native-inputs
-     (list intltool
+     (list bash-completion
+           docbook-xsl
+           gettext-minimal
+           `(,glib "bin")
+           gobject-introspection
+           libxml2                      ;for XML_CATALOG_FILES
+           libxslt
            pkg-config
            python-wrapper
-           `(,glib "bin")))
+           vala))
     (inputs
-     (list glib bash-completion polkit))
-    (propagated-inputs
-     (list sqlite))
+     (list glib
+           gstreamer
+           gst-plugins-base
+           gtk+
+           polkit))
+    (propagated-inputs (list sqlite))
     (home-page "https://www.freedesktop.org/software/PackageKit/")
     (synopsis "API for package management, through D-Bus")
     (description