summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-22 14:34:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-22 14:39:03 +0200
commitc89afe7516a45854d5b0975c24478c47e21fefd7 (patch)
tree0782642b2d11b60a8c6e8e59d1393dc1b22ce1d3 /gnu
parent277ac1f242084a7a5048cd07390c04cf277f80c3 (diff)
downloadguix-c89afe7516a45854d5b0975c24478c47e21fefd7.tar.gz
gnu: Add r-rgreat.
* gnu/packages/bioconductor.scm (r-rgreat): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index cfdd3d1c5e..002f4a0edb 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8089,3 +8089,31 @@ metrics, such as the elbow method and Horn's parallel analysis, which has
 relevance for data reduction in single-cell RNA-seq (scRNA-seq) and high
 dimensional mass cytometry data.")
     (license license:gpl3)))
+
+(define-public r-rgreat
+  (package
+    (name "r-rgreat")
+    (version "1.20.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "rGREAT" version))
+       (sha256
+        (base32
+         "0n8dw9ibb2klsczcxvvinpi9l53w8cs436i0c8w2jmramayl593v"))))
+    (properties `((upstream-name . "rGREAT")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-genomicranges" ,r-genomicranges)
+       ("r-getoptlong" ,r-getoptlong)
+       ("r-iranges" ,r-iranges)
+       ("r-rcurl" ,r-rcurl)
+       ("r-rjson" ,r-rjson)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/jokergoo/rGREAT")
+    (synopsis "Client for GREAT analysis")
+    (description
+     "This package makes GREAT (Genomic Regions Enrichment of Annotations
+Tool) analysis automatic by constructing a HTTP POST request according to
+user's input and automatically retrieving results from GREAT web server.")
+    (license license:expat)))