summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-19 13:22:52 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-19 13:22:52 +0000
commitd5f89c0b938fdfb82639db70a4a1c135e993ea49 (patch)
treed8be3271586322e31f749d857d340d80a62c2b06 /gnu
parentfcd17fdeac963a0c1a8f8410d061f0b6766aebf4 (diff)
downloadguix-d5f89c0b938fdfb82639db70a4a1c135e993ea49.tar.gz
gnu: python-boto3: Update to 1.18.64.
* gnu/packages/python-xyz.scm (python-boto3): Update to 1.18.64.
[arguments]: Remove trailing #t.
[native-inputs]: Add python-pytest.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7e7456bce9..fa1fec6b5b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13495,7 +13495,7 @@ interface to the Amazon Web Services (AWS) API.")
 (define-public python-boto3
   (package
     (name "python-boto3")
-    (version "1.16.22")
+    (version "1.18.64")
     (home-page "https://github.com/boto/boto3")
     (source (origin
               (method git-fetch)
@@ -13503,19 +13503,19 @@ interface to the Amazon Web Services (AWS) API.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0h20hgl4yfl58g75qhb6ibrdmzn47md3srgar7hask14cjmfhfy3"))))
+                "02hy80xfyxln5yr43cbrmq3kpkdijv8v228alz1x92y4gghnb8cj"))))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'delete-network-tests
            ;; Deleting integration tests because they are trying to connect to AWS.
 	   (lambda _
-	     (delete-file-recursively "tests/integration")
-	     #t)))))
+	     (delete-file-recursively "tests/integration"))))))
     (build-system python-build-system)
     (native-inputs
      `(("python-nose" ,python-nose)
-       ("python-mock" ,python-mock)))
+       ("python-mock" ,python-mock)
+       ("python-pytest" ,python-pytest)))
     (propagated-inputs
      `(("python-botocore" ,python-botocore)
        ("python-jmespath" ,python-jmespath)