summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-25 10:19:13 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-25 11:46:08 +0200
commitd6ab1d0ac3047931a4e4daf0d48f23d2468a7341 (patch)
treef65745bfd4729ef66a6200498846d2cb2a467672 /gnu
parentbbc69023d86f5bd4ffec994453e5bdfbf5c429f4 (diff)
downloadguix-d6ab1d0ac3047931a4e4daf0d48f23d2468a7341.tar.gz
gnu: python-flask-login: Update to 0.4.1.
* gnu/packages/python-web.scm (python-flask-login): Update to 0.4.1.
[arguments]: Run the test suite.
[propagated-inputs]: Add python-flask.
[native-inputs]: Add test dependencies.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 20 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e3de0a0824..456134c1ce 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2053,7 +2053,7 @@ It comes with safe defaults and easily configurable options.")
 (define-public python-flask-login
   (package
     (name "python-flask-login")
-    (version "0.4.0")
+    (version "0.4.1")
     (source
      (origin
        (method git-fetch)
@@ -2062,12 +2062,27 @@ It comes with safe defaults and easily configurable options.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0sjbmk8m4mmd9g99n6c6lx9nv2jwwqp6qsqhl945w2m0f1sknwdh"))))
+        (base32 "1rj0qwyxapxnp84fi4lhmvh3d91fdiwz7hibw77x3d5i72knqaa9"))))
     (arguments
-     ;; Tests fail PEP8 compliance. See:
-     ;; https://github.com/maxcountryman/flask-login/issues/340
-     `(#:tests? #f))
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'avoid-yanc
+           ;; Work around '.nosetests-real: error: no such option: --with-yanc'.
+           (lambda _
+             (setenv "NOCOLOR" "set")
+             #t)))))
     (build-system python-build-system)
+    (propagated-inputs
+     `(("python-flask" ,python-flask)))
+    (native-inputs
+     ;; For tests.
+     `(("python-blinker" ,python-blinker)
+       ("python-mock" ,python-mock)
+       ("python-nose" ,python-nose)
+       ("python-pep8" ,python-pep8)
+       ("python-pyflakes" ,python-pyflakes)
+       ("python-semantic-version" ,python-semantic-version)
+       ("python-werkzeug" ,python-werkzeug)))
     (home-page "https://github.com/maxcountryman/flask-login")
     (synopsis "User session management for Flask")
     (description