summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:13:34 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:52 -0400
commitea969c6b047f5bc9653ce6a84650a7d0fa73955c (patch)
treef23be3465dfcec4e1ca0e96d16929db65c5a1ed2 /gnu
parente4ef47721272c2f4286eaad1bbc3028a30fa9988 (diff)
downloadguix-ea969c6b047f5bc9653ce6a84650a7d0fa73955c.tar.gz
gnu: Add go-golang-org-x-text-unicode-norm.
* gnu/packages/syncthing.scm (go-golang-org-x-text-unicode-norm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/syncthing.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 8597ba9c81..02c39dea64 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1193,6 +1193,32 @@ between character sets.")
       (home-page "https://go.googlesource.com/text")
       (license bsd-3))))
 
+(define-public go-golang-org-x-text-unicode-norm
+  (let ((commit "f4b4367115ec2de254587813edaa901bc1c723a8")
+        (revision "0"))
+    (package
+      (name "go-golang-org-x-text-unicode-norm")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://go.googlesource.com/text")
+                      (commit commit)))
+                (file-name (string-append "go.googlesource.com-text-"
+                                          version "-checkout"))
+                (sha256
+                 (base32
+                  "1a5m97y7sdxks02p4swg8ffp8bgr95aaf5fhfw511p7h3xg1dm0d"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "golang.org/x/text/unicode/norm"
+         #:unpack-path "golang.org/x/text"))
+      (synopsis "Unicode normalization in Go")
+      (description "This package provides @code{norm}, which contains types and
+functions for normalizing Unicode strings.")
+      (home-page "https://go.googlesource.com/text")
+      (license bsd-3))))
+
 (define-public go-github-com-petermattis-goid
   (let ((commit "3db12ebb2a599ba4a96bea1c17b61c2f78a40e02")
         (revision "0"))