summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-08-22 18:13:36 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:13 +0100
commitee62d19d9e098afc131d1c329f39a5d8e5167c4c (patch)
tree4538370eaf19e4bfe7e886a8600a7f81cf910dd0 /gnu
parent60caef04e69fff529cb127bd0c236e7199faf0fd (diff)
downloadguix-ee62d19d9e098afc131d1c329f39a5d8e5167c4c.tar.gz
gnu: Add powerdevil.
* gnu/packages/kde-plasma.scm (powerdevil): New variable.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-plasma.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index eb5f137aca..d537285834 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1815,6 +1815,50 @@ UI for Plasma")
     (home-page "https://invent.kde.org/plasma/polkit-kde-agent-1")
     (license license:gpl2+)))
 
+(define-public powerdevil
+  (package
+    (name "powerdevil")
+    (version "5.25.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/plasma/" version
+                                  "/" name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0anisirn7z8aw442npdnk1csb5ghpzj2hx49gpw4l6ijk70b76pr"))))
+    (build-system qt-build-system)
+    (native-inputs (list extra-cmake-modules qttools-5 pkg-config))
+    (inputs (list bluez-qt
+                  glib
+                  kauth
+                  kactivities
+                  kscreen
+                  kidletime
+                  kconfig
+                  kdbusaddons
+                  solid
+                  ki18n
+                  kcrash
+                  knotifyconfig
+                  networkmanager-qt
+                  kio
+                  kwayland
+                  kglobalaccel
+                  kcrash
+                  knotifications
+                  kirigami
+                  libcap
+                  libkscreen
+                  network-manager
+                  plasma-workspace
+                  eudev
+                  qtx11extras))
+    (synopsis "Manage power consumption")
+    (description "This package provides the power consumption settings
+of a Plasma shell.")
+    (home-page "https://invent.kde.org/plasma/powerdevil")
+    (license license:gpl2+)))
+
 (define-public system-settings
   (package
     (name "system-settings")