summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-02-14 14:27:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-15 17:18:50 +0100
commitfc162dbaec1348d42361e0f12fc0ea731d53141b (patch)
tree7487acc9d6f792b4163403cc7022f8d5ba770857 /gnu
parent130d290e29fa3af4567fba1132c55cedd2d0e11a (diff)
downloadguix-fc162dbaec1348d42361e0f12fc0ea731d53141b.tar.gz
gnu: Add python-typing.
* gnu/packages/python.scm (python-typing, python2-typing): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b05a4a4a2b..c3459cc51f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12707,3 +12707,28 @@ and @code{tokens_to_src} to roundtrip.")
 source bytes using the UTF-8 encoding and then rewrites Python 3.6 style
 @code{f} strings.")
     (license license:expat)))
+
+(define-public python-typing
+  (package
+    (name "python-typing")
+    (version "3.6.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "typing" version))
+       (sha256
+        (base32
+         "1wmk9nkh30n37cbrqwkbggmj2390lhrlagjkd0ikm02l88saj06l"))))
+    (build-system python-build-system)
+    (home-page "https://docs.python.org/3/library/typing.html")
+    (synopsis "Type hints for Python")
+    (description "This is a backport of the standard library @code{typing}
+module to Python versions older than 3.5.  Typing defines a standard notation
+for Python function and variable type annotations.  The notation can be used
+for documenting code in a concise, standard format, and it has been designed
+to also be used by static and runtime type checkers, static analyzers, IDEs
+and other tools.")
+    (license license:psfl)))
+
+(define-public python2-typing
+  (package-with-python2 python-typing))