summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-01-27 11:51:43 +0100
committerLudovic Courtès <ludo@gnu.org>2021-01-27 22:55:40 +0100
commitc45a821a63b73e1655314c028315114f34b26417 (patch)
treec0805c9747e094fbaa4eafd7de70f9cd2dfad3fd /gnu
parenta04b0e454ce366df78fa28b83721ecafe8ca26f3 (diff)
downloadguix-c45a821a63b73e1655314c028315114f34b26417.tar.gz
gnu: guile-gcrypt: Refer to the right libgcrypt when cross-compiling.
Fixes a regression introduced in
5e163ba00969e7ba05897840a1199b967252b4ae where (gcrypt package-config)
would end up referring to the native libgcrypt.so instead of the target
one.

* gnu/packages/gnupg.scm (guile-gcrypt)[arguments]: Reintroduce
'add-libgrypt-config' phase.
[native-inputs]: Remove LIBGCRYPT.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnupg.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 5c8207e875..6e80ca339f 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -436,14 +436,24 @@ gpgpme starting with version 1.7.")
     (arguments
      ;; Work around <https://bugs.gnu.org/20272> to achieve reproducible
      ;; builds.
-     '(#:parallel-build? #f))
+     '(#:parallel-build? #f
+
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'add-libgrypt-config
+           (lambda* (#:key inputs target #:allow-other-keys)
+             (when target
+               ;; When cross-compiling, the bash script 'libgcrypt-config'
+               ;; must be accessible during the configure phase.
+               (setenv "PATH"
+                       (string-append (assoc-ref inputs "libgcrypt")
+                                      "/bin:" (getenv "PATH")))))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("autoconf" ,autoconf)
        ("automake" ,automake)
        ("texinfo" ,texinfo)
-       ("guile" ,guile-3.0)
-       ("libgcrypt" ,libgcrypt)))                 ;for 'libgcrypt-config'
+       ("guile" ,guile-3.0)))
     (inputs
      `(("guile" ,guile-3.0)
        ("libgcrypt" ,libgcrypt)))