summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-10 18:09:00 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-10 18:09:46 +0200
commit3314f8a7b6e92ba77a1706251703f1783d456824 (patch)
tree98a018e35e7b1304aecafb587453a19e7349e089 /gnu
parentb3455870e1225d14ebeae6738e10bd3e1bbcf626 (diff)
downloadguix-3314f8a7b6e92ba77a1706251703f1783d456824.tar.gz
gnu: libtool: Leave out the test suite workarounds.
They are no longer needed since the latest ld-wrapper changes (commit
51d0cd9.)

* gnu/packages/patches/libtool-skip-tests2.patch: New file.
* gnu/packages/autotools.scm (libtool)[source]: Use it.
* gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/autotools.scm5
-rw-r--r--gnu/packages/patches/libtool-skip-tests2.patch33
2 files changed, 37 insertions, 1 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 4b5cbb6dfd..bc2b20ed46 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -248,7 +248,7 @@ Makefile, simplifying the entire process for the developer.")
                (base32
                 "0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))
               (patches
-               (list (search-patch "libtool-skip-tests.patch")))))
+               (list (search-patch "libtool-skip-tests2.patch")))))
     (build-system gnu-build-system)
     (propagated-inputs `(("m4" ,m4)))
     (native-inputs `(("m4" ,m4)
@@ -304,6 +304,9 @@ complexity of working with shared libraries across platforms.")
               (sha256
                (base32
                 "0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))
+
+              ;; FIXME: We don't need this patch here, we just keep it to
+              ;; avoid a rebuild today.
               (patches
                (list (search-patch "libtool-skip-tests.patch")))))
     (build-system gnu-build-system)
diff --git a/gnu/packages/patches/libtool-skip-tests2.patch b/gnu/packages/patches/libtool-skip-tests2.patch
new file mode 100644
index 0000000000..c9d61e3b41
--- /dev/null
+++ b/gnu/packages/patches/libtool-skip-tests2.patch
@@ -0,0 +1,33 @@
+Skip the nopic test on ARM and MIPS systems.
+
+--- libtool-2.4.6/tests/demo.at.orig	2015-01-16 13:52:04.000000000 -0500
++++ libtool-2.4.6/tests/demo.at	2015-02-16 10:48:51.435851966 -0500
+@@ -510,7 +510,7 @@
+ AT_SETUP([force non-PIC objects])
+ 
+ AT_CHECK([case $host in
+-hppa*|x86_64*|s390*)
++hppa*|x86_64*|s390*|arm*|mips*)
+   # These hosts cannot use non-PIC shared libs
+   exit 77 ;;
+ *-solaris*|*-sunos*)
+--- libtool-2.4.6/tests/testsuite.orig	2015-02-15 11:15:25.000000000 -0500
++++ libtool-2.4.6/tests/testsuite	2015-02-16 10:50:58.736483216 -0500
+@@ -8741,7 +8741,7 @@
+ 
+ { set +x
+ $as_echo "$at_srcdir/demo.at:535: case \$host in
+-hppa*|x86_64*|s390*)
++hppa*|x86_64*|s390*|arm*|mips*)
+   # These hosts cannot use non-PIC shared libs
+   exit 77 ;;
+ *-solaris*|*-sunos*)
+@@ -8766,7 +8766,7 @@
+ "
+ at_fn_check_prepare_notrace 'a `...` command substitution' "demo.at:535"
+ ( $at_check_trace; case $host in
+-hppa*|x86_64*|s390*)
++hppa*|x86_64*|s390*|arm*|mips*)
+   # These hosts cannot use non-PIC shared libs
+   exit 77 ;;
+ *-solaris*|*-sunos*)