summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-07 15:49:44 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:51 -0500
commit4dbac597ebd322ed1b3c851e3e657407a4b41f23 (patch)
treecc365c2752e06d3d217edb18fdf6d98e09ffe477 /gnu
parent7332618df3987785402d6d8f5931b172002804c6 (diff)
downloadguix-4dbac597ebd322ed1b3c851e3e657407a4b41f23.tar.gz
gnu: Add Test-MockObject.
* gnu/packages/perl.scm (perl-test-mockobject): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 15b7d9a50c..efa94beab6 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4659,6 +4659,34 @@ string comparison functions of Test::More, but which are more suitable when
 you test against long strings.")
     (license (package-license perl))))
 
+(define-public perl-test-mockobject
+  (package
+    (name "perl-test-mockobject")
+    (version "1.20140408")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/C/CH/CHROMATIC/"
+                           "Test-MockObject-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1anpf9l2wdriwaxw6pf76ghxkh4zm25n3wnhfqy1b439xqnhvzg5"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-exception" ,perl-test-exception)
+       ("perl-test-warn" ,perl-test-warn)))
+    (propagated-inputs
+     `(("perl-test-exception" ,perl-test-exception)
+       ("perl-test-warn" ,perl-test-warn)
+       ("perl-universal-can" ,perl-universal-can)
+       ("perl-universal-isa" ,perl-universal-isa)))
+    (home-page "http://search.cpan.org/dist/Test-MockObject")
+    (synopsis "Emulate troublesome interfaces in Perl")
+    (description "Test::MockObject allows you to create objects that conform
+to particular interfaces with very little code.  You don't have to reimplement
+the behavior, just the input and the output.")
+    (license (package-license perl))))
+
 (define-public perl-test-mocktime
   (package
     (name "perl-test-mocktime")