summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 14:32:25 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit4f99755142ccc270ae4103cea1ec024fceac0b45 (patch)
treec5b693643d7036ee7393c7aa35f306b9e9b46023 /gnu
parent03f6074b72ebfc0711b9a6de4d604ac73b02929e (diff)
downloadguix-4f99755142ccc270ae4103cea1ec024fceac0b45.tar.gz
gnu: Add ghc-bifunctors.
* gnu/packages/haskell.scm (ghc-bifunctors): Add variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9570e68454..6703683619 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2433,6 +2433,29 @@ unbounded @code{Integer} type.")
 given term should not exist.")
     (license bsd-3)))
 
+(define-public ghc-bifunctors
+  (package
+    (name "ghc-bifunctors")
+    (version "5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://hackage.haskell.org/package/bifunctors/bifunctors-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "13990xdgx0n23qgi18ghhmsywj5zkr0a5bim0g8a4nzi0cx95ps1"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-tagged" ,ghc-tagged)
+       ("ghc-semigroups" ,ghc-semigroups)))
+    (home-page "http://github.com/ekmett/bifunctors/")
+    (synopsis "Bifunctors for Haskell")
+    (description "This package provides bifunctors for Haskell.")
+    (license bsd-3)))
+
 (define-public ghc-semigroups
   (package
     (name "ghc-semigroups")