summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-09-15 16:26:30 +0200
committerAndreas Enge <andreas@enge.fr>2014-09-15 16:26:30 +0200
commit6b8e828577a6e1f03b3f760e5d5261b0131ced6f (patch)
treec59a9e0fb8da30e2a13ba0849d9beab286cffbdb /gnu
parent2274b8163a40e2ebaf90e2b434fd2d9c757b539e (diff)
downloadguix-6b8e828577a6e1f03b3f760e5d5261b0131ced6f.tar.gz
gnu: Add arb.
* gnu/packages/algebra.scm (arb): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/algebra.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 7fc31abae7..53382eb67b 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -205,6 +205,49 @@ fast arithmetic.")
    (license gpl2+)
    (home-page "http://flintlib.org/")))
 
+(define-public arb
+  (package
+   (name "arb")
+   (version "2.2.0")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append
+                  "https://github.com/fredrik-johansson/arb/archive/"
+                  version ".tar.gz"))
+            (sha256 (base32
+                     "0a8cgzznkmr59ngj4di9a37b5h4i00gbnixnxlwd34bcbflvjzyr"))))
+   (build-system gnu-build-system)
+   (inputs
+    `(("flint" ,flint)
+      ("gmp" ,gmp)
+      ("mpfr" ,mpfr)))
+   (arguments
+    `(#:phases
+        (alist-replace
+         'configure
+         (lambda* (#:key inputs outputs #:allow-other-keys)
+           (let ((out (assoc-ref outputs "out"))
+                 (flint (assoc-ref inputs "flint"))
+                 (gmp (assoc-ref inputs "gmp"))
+                 (mpfr (assoc-ref inputs "mpfr")))
+             ;; do not pass "--enable-fast-install", which makes the
+             ;; homebrew configure process fail
+             (zero? (system*
+                     "./configure"
+                     (string-append "--prefix=" out)
+                     (string-append "--with-flint=" flint)
+                     (string-append "--with-gmp=" gmp)
+                     (string-append "--with-mpfr=" mpfr)))))
+         %standard-phases)))
+   (synopsis "Arbitrary precision floating-point ball arithmetic")
+   (description
+    "Arb is a C library for arbitrary-precision floating-point ball
+arithmetic.  It supports efficient high-precision computation with
+polynomials, power series, matrices and special functions over the
+real and complex numbers, with automatic, rigorous error control.")
+   (license gpl2+)
+   (home-page "http://fredrikj.net/arb/")))
+
 (define-public bc
   (package
     (name "bc")